
SQL Analysis Services 2005 
Exercises 

 
1 Creating a multidimensional database 
 
Start Business Intelligence Development Studio 
Programs → Microsoft SQL Server → Business Intelligence Development Studio 
Create a new project  
File → New Project → Choose Analysis Service Project → Give a name to the project 
Create a Data Source 
Right click Data Sources → New Data Source → Create a new connection by clicking on 
New … → Select server → Select the database AdventureWorksDW → Next → Use the 
service account → Finish the wizard 
Create a Data Source View 
Right click Data Source Views → New Data Source View → Select AdventureWorksDW → 
Choose the tables Dim Currency, DimCustomer, DimEmployee, DimProduct, DimPromotion, 
DimReseller, DimSalesTerritory, DimTime, FactInternetSales, and FactResellerSales → 
Finish the wizard 
Create a Cube 
Right click Cubes → New Cube → Continue the wizard → Select AdventureWorksDW DSV 
→ Continue the wizard → In the dialog Identify Fact and Dimension Tables define 
DimReseller as only a Dimension→ Continue the wizard until the end. 
Deploy and Browse a Cube 
Right click Project name → Deploy → In the Browser drag and drop the English Promotion 
Category of dimension DimPromotion on the Column field and the hierarchy Sales Territory 
Group of dimension DimSalesTerritory on the Row field → Drag and drop Measure Sales 
Amount in the Data area 
Analyze the measures using different combinations of dimensions at different hierarchical 
levels in order to obtain strategic information about AdventureWorks’ sales (both Reseller 
and Internet). 
Start SQL Server Management Studio 
Programs → Microsoft SQL Server → SQL Server Management Studio → Connect to 
Analysis Services Server 
View all different objects of the AdventureWorksDW,  
 
2 Visualizing and customizing the tables in the Data Source View 
Visualizing the tables 
Right click on the table FactInternetSales→ Explore Data 
Visualize a sample of the contents. Notice that the columns CarrierTracking and 
CustomerPON have only null values. 
Click on the Pivot Table tab, drag and drop columns of the table inside the row, column, 
details or filter areas. 
Click on the Chart tab and see the charts associated to the different columns. 
Creating a view of the FactInternetSales table 
Right click on FactInternetSales table → Replace Table → With New Named Query 
Create a view by hiding one or several columns (e.g., CarrierTracking and CustomerPON) or 
by selecting particular values on one or several columns, (e.g., those that have a Freight > 18). 
Visualize again the contents of the table. 
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Add a new column to the Employee table 
Right click on Employee table → New Named Calculation 
Create a column Full Name as FirstName + ' ' + MiddleName + ' ' + LastName 
Visualize the table and see what happens for employees that do not have a MiddleName. 
Correct the problem. 
Create a new diagram (or view) in the Data Source View for the Internet Sales 
Right click on Diagram Organizer → New Diagram → Give a name to the diagram 
Right click on the diagram view → Show tables 
Select the tables related to the InternetSales fact table. 
 
3 Customizing and visualizing dimensions 
Adding a new dimension table 
Double click on the DSV AdventureWorksDW.dsv → Click on the Add/Remove objects icon 
(top left icon in the DSV Designer) → Add the DimGeography dimension 
Defining a new dimension 
Right click on Dimensions in the Solutions Explorer → New Dimension → Continue the 
wizard → In the Select Main Dimension table dialog select the DimGeography table → Finish 
the wizard 
Defining one-to-many relationships between attributes 
In tree view of the Attributes pane expand the node showing attribute City → Drag and drop 
attribute State Province Name from the attribute list to the new attribute relationship under the 
City node → Follow the same steps for the English Country Region Name → Similarly 
specify English Country Region name as member property of State Province Name 
Defining hierarchies 
Drag and drop attribute English Country Region Name from the Attributes pane to the 
Hierarchy and Level pane → Right click on the attribute within the hierarchy  →  Rename →  
Rename the attribute Country 
Drag and drop State Province Name from the Attributes pane to the Hierarchy pane such that 
the State Province Name is below Country in the hierarchy → Rename it to State-Province 
Drag and drop City and DimGeography attributes to the hierarchy to create a four-level 
hierarchy Country-State-City-DimGeography. 
Rename the hierarchy by right-clicking on Hierarchy → Rename it to Geography 
Deploy the project  
Visualizing a dimension  
In the Dimension Designer switch to the Browser pane select the Geography hierarchy and 
expand the levels starting from All. 
Go to the Dimensions Structure tab → Click on the Geography hierarchy → In the properties 
window set the AllMemberName property to All countries → Deploy the project → Visualize 
the Geography hierarchy again. If necessary reconnect (2nd button from the left) to retrieve the 
latest data from the Analysis Service instance. 
Creating a snowflake dimension 
Open the DSV and click on the Add/Remove Tables icon → Add the tables 
DimProductCategory and DimProductSubcategory. 
Delete the current Dim Products dimension to be able to create it as a snowflake dimension → 
Launch the Dimension wizard accepting the defaults → Select DimProduct table as main 
dimension table → Select DimProductCategory and DimProductSubcategory as related tables 
→ Finish the wizard. 
Notice in the DSV pane the three related tables. Notice that the attributes of the dimension 
refer to attributes from the three tables. 
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Creating a time dimension 
Delete the current Dim Time dimension. 
Launch the Dimension wizard → On the Dimension Type page select Time dimension and 
choose the DimTime table → On the Define Time Periods dialog define the properties Year, 
Half Year, Quarter, Month, and Date with the columns CalendarYear, CalendarSemester, 
CalendarQuarter, EnglishMonthName, and DayNumberOfMonth, respectively → Finish the 
wizard → Deploy the project → Browse the dimension  
In order to change the order of months in the default calendar order it is necessary to change 
the KeyColumns in the Source Properties → Click on the … button → Remove the current 
member → Add a new binding → Click in the Source properties → Click on the … button → 
Select Column binding as binding type → Select MonthNumberOfYear as source column → 
In the Advanced Properties verify that the OrderBy property is set to Key → Redeploy the 
project → Browse the dimension again to verify the changes 
Creating a parent-child hierarchy 
Delete the current Dim Employee dimension. 
Launch the Dimension wizard to create a standard dimension on the DimEmployee table → 
Continue with the wizard until the end → Deploy the project → Browse the dimension 
To see the names of the employees rather than their ids it is necessary to modify the named 
column of the DimEmployee attribute → Change the named column of the Key attribute to 
FullName → Redeploy the project → Browse the dimension. 
 
4 Customizing and visualizing cubes 
Creating a cube 
Delete the existing cube by right clicking on the it and select Delete. 
Right-click the Cubes folder and select New Cube → Continue the wizard → On the Identify 
Fact and Dimension Tables page select DimReseller table as only a dimension table, not a fact 
table → In the Review Shared Dimensions page Select all available dimensions as → 
Continue the wizard until the end. 
Visualize the structure of the cube. Notice that DimTime is used in the definition of the three 
cube dimensions OrderDate, ShipDate, and DueDate. 
Browsing a cube 
Deploy the project in order to browse the cube using the Brows tab. Suppose you want to 
analyze the Internet sales of products based on the promotions offered to customers and the 
marital status of those customers: Drag and drop Dim Promotion.English Promotion Type to 
the rows → Drag and drop Dim Customer.Marital Status to the columns → Drag and drop the 
measure Fact Internet Sales.Sales Amount to the Detail Fields 
Dimension Types 
Select the Dimension Usage tab to see the relationships between the dimensions and the 
measure groups of the cube. In this example the relationships are either regular relationship 
(no icon shown in the cell), or reference relationship (arrow icon in the cell), or there is no 
relationship (grayed cell). 
Adding a reference relationship 
Add the Dim Geography dimension to the cube: In the Dimensions pane of the Cube Structure 
tab right click on the cube → Add Cube Dimension → Select the Geography dimension 
Go to the Dimension Usage page to define a reference relationship between Dim Geography 
and Fact Internet Sales measure group select the corresponding cell in the matrix → Click on 
… → In the Define Relationship dialog box select Referenced as relationship type → In the 
Intermediate dimension select the Dim Customer dimension → Select Reference dimension 
attribute as Dim Geography and Intermediate dimension attribute as Geography Key. 
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In the same way establish a referenced relationship between the DimGeography dimension 
and the Fact Reseller Sales measure group through the Dim Reseller dimension. 
Browsing a reference dimensions 
Suppose that you want to analyze the Reseller Sales based on different business types in 
various countries. 
In the Cube Browser drag and drop the Geography hierarchy from the Dim Geography 
dimension to the rows, the Business Type Hierarchy of Dim Reseller dimension to the 
columns and the measure Sales Amount of the Fact Reseller Sales measure group to the 
details area. 
Measure Properties 
In the Cube Structure tab, click the cube within the Measures pane to see the associated 
properties in the Properties window. One important property is the StorageMode: it can be 
MOLAP, ROLAP, or HOLAP. 
Click on a measure group to see the associated properties → Select the measure Fact Internet 
Sales.Sales Amount and notice the aggregation function used. 
 
Adding measures 
Suppose you want to create two measures counting the number of customers and the number 
of distinct customers. 
Drag and drop the Customer Key column from the Fact Internet Sales table in the DSV of the 
cube editor to the Measures pane → In the Properties pane change the name for this measure 
to Distinct Customers by right clicking on the measure and selecting Rename → Change the 
aggregate function for this measure to Distinct Count 
Drag and drop the Customer Key column once again from the DSV to the Measures pane. 
Rename it to Total Customers and change the aggregate function to Count. 
The Unit Price – Fact Internet Sales of a product should not be aggregated → Choose the 
aggregate function FirstNonEmpty. 
Create a hierarchy called Products in the Dim Product dimension with two levels Model 
Name and English Product Name → Rename the level English Product Name as Product 
Name 
Deploy the project 
In the Cube Browser, drag and drop the measures Sales Amount – Fact Internet Sales, Total 
Customers, Unit Price – Internet Sales Amount, and Distinct Customers to the data area → 
Drag and drop the hierarchy Products from the Dim Product dimension to the rows → Expand 
a member and see the different aggregation functions for the measures  
Calculated measures 
Creating two calculated measures for the total sales and the total cost from Internet and 
Reseller sales. 
In the Calculations tab, right click in the Script Organizer pane → New calculated member → 
Specify the name as Total Sales Amount → Drag and drop the sales amounts in Fact Internet 
Sales and Fact Reseller Sales measures groups and add the + operator between the two. 
Similarly, create a new calculated measure called Total Products Costs. 
Create a calculated measure called Profit as the difference of the two previous calculated 
measures → Enter the following MDX expression for the background color: 
 iif ( [Measures].Profit < 1000000, 255 /* Red */, 65280 /* Green */ )  
To see the effect of the calculations go to the Cube Browser and deploy the project → Drag 
and drop the measure Profit to the detail area, hierarchy English Country Region name on the 
Dim Geography dimension on rows and hierarchy Style of the Dim Product dimension on 
columns. 
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Creating perspectives 
Create a perspective for Internet sales and another for Reseller Sales 
Click the Perspective tab in the Cube Designer → Right click in the window pane → New 
Perspective → Rename the perspective Internet Sales → Deselect the Fact Reseller Sales 
measure group and the dimensions Dim Employee and Dim Reseller. 
Create another perspective called Reseller Sales. Deselect the Fact Internet Sales measure 
group and Dim Customer. 
Deploy the project → In the Browser tab of the Cube Designer click in the Perspective list 
box and Select the Internet Sales perspective → Drag and drop the Sales Amount – Fact 
Internet Sales, English Product Name hierarchy in the Dim Product dimension and the 
English Education Name hierarchy of the Dim Customer dimension to the browser. 
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